Blitz not loading HELP! After discussion appears OPTUS have shat the bed

Ok, hoping there is a guru here that can assist. I am having an issue opening Blitz. I have tried 4 different browsers on my laptop (Firefox, Chrome, Opera, Edge and even Firefox developer), running through my Optus modem and it just sits there doing nothing. Every other site I try to visit works fine. I disconnect my Optus Modem and hook up my Telstra phone as a USB modem and it loads fine. I have tried restarting each browser. I have logged off and back on. I have restarted the laptop. I have restarted the Modem and rest the modem. None of this has worked.

edit: I have also cleared the cache and cookies and deleted all history.

Anyone able to offer help?

I was having the same trouble on my iPad about an hour ago.

Coincidentally, I’m with Optus.

Working now though?

I can only assume Blitz is buckling under the weight of the Adams Goodes thread.

3 Likes

Working on my phone, not through modem.

Same here, but different network

Nah, working fine through my phone on the Telstra network

Yeah same issue wont load on computer works fine on my phone

What network you with?

Optus has been having issues for hours

Optus home internet
Telstra mobile

But only with Blitz? Youtube, Twitter, Facebook all opened no worries at all.

1 Like

Optus is having trouble tonight, it is all over their twitter feed.

https://twitter.com/Optus?ref_src=twsrc^google|twcamp^serp|twgr^author

It’s certain international servers

Yeah few other websites as well
Seems very random

1 Like

Okay, I’ll just live with using my mobile data for now. Thankfully I have plenty.

1 Like

Issues with me as well, on Optus. Currently connected via VPN with no issues.

1 Like

@ivan see discussion in here.

1 Like

Ah, ok, this all makes sense. Turn the WiFi off my phone and the site loads.

It’s an Optus thing.

Website Design